Technical
critical-security-alert-if-you-havent-patched-this-two-year-old-vpn-vulnerability-assume-your-network-is-compromised

why old cybersecurity vulnerabilities are still a problem!

Hundreds of organizations that haven’t applied a Fortinet VPN security update released in 2019 should assume that cybercriminals are trying to take advantage, NCSC warns. Cybercriminals and nation-state cyber-espionage operations are actively scanning for unpatched vulnerabilities in Fortinet VPNs; organizations that use Fortigate firewalls on their network, and have yet to apply a critical security […]